Render Plus Software

So far my Evaluation of Space Design went pretty well and I think this might be the right choice for my company.

Now there is one problem left I'm facing, and that is saving space design attributes so I can just start up a new drawing, import some components and immediately have cost/weight/etc ready for reporting, but the SD attributes are not saved in a component like the DC attributes are. I've seen a bunch of topics about this, all without answer though.

Now actually I already have my solution for this, as I can just save a cost/weight/etc DC attribute in my component and then map that attribute to the according SD attribute, already tested it and it works like a charm. The problem would be to save the mapping, because neither with reloading a saved .sda nor a saved .sds do I get the mapping back. My mistake or is there no way to save the mappings currently?

Views: 271

Reply to This

Replies to This Discussion

I mapped DC:lenx to Cost

And then save that as my project attributes:

Then all I need to do is Load from Project before making the report, and that works for me. I get the lenx value reported as my cost.

Is that similar to what you are trying to do? or is the mapping that you are doing something else?

I used the Map Attributes button which is in the same window:Actually your way of Mapping (%DC: [attribute name]%) doesn't work for me, whereas mapping the attributes like this works normally. I just have no way to save that setting apparently, save/load to/from project doesn't work either.

Originally I tried mapping the way you described, but when it didn't work I assumed that was not the way to do it and used Map Attributes, but now I'm confused why I get a different result when doing the same thing.

In order to save SpaceDesign attributes on SketchUp components, so that when you place a component it will have a specific default attribute like Cost, you need to either learn to use the Ruby interface to place the attribute on the model before you save it as a component, or use the Create Attributes for Components dialog: 

This works by having all of the components in a local collection in one model and saving a CSV file of the attributes that you can use to change the SpaceDesign attributes for the components before you save, or resave, them as a local collection. Once this is done, when you place those components from the collection, they will have the saved attributes, but still can be over-ridden on instances of the component placed in the model.

This is explained here:

http://www.renderplus.com/wp2/wk/Auto_Generate_Attributes.htm

I just tested this, and found that I had broken this last week, when I added that fix for the Locale number and currency settings, so I posted a new version, NG02, that you will need to install before seeing if this works for you.

However, I think you what you need is a solution that will generate the attributes based on the Dynamic component attributes. Could you post a couple of components that I could use to see why mapping or simply assigning the dynamic attribute to another attribute doesn't work for you? 

You can email them to me at rich.hart@renderplus.com

Then I can place them and see why the attributes and mappings are not being saved. This is something that definitely needs to work.

Auto generating the attributes might work out but it's not something I want to have to teach my colleagues, especially as the mapping of DC attributes is much faster and more efficient as it does not require as much maintenance.

I have sent you an E-Mail with 2 components I used and 3 pictures detailing the steps I have taken.

(Just a small side note, on the page you linked above there is a typo, somewhere around the middle there is Exel written instead of Excel.)

Your DC:cost attribute works for me, without using Mappping.

Could you try these steps:

Make sure that "DC:cost" is set to be included in the report, but mark it to be suppressed so we won't see it as a column;

"Edit" the attribute "cost" and use the "Add attribute to calculation" combo box to select "DC:cost" for the calculation. And click OK.

That should put "%DC:cost%", in the calculation field. You cannot just add the text there manually, you have to do it using the Edit dialog to set the calculation, for some reason.

When I do that, I see this in the report:

Does that work for you?

Putting the text in manually works as well though, so I can actually skip the dialog box. it seems the only relevant part I missed out on was to put report+suppress for DC: cost.
Did you write "%DC:cost%" or "%DC: cost%"? The space makes the difference for me.

And for your 2 E-Mail replies, I tested all suggested steps and now I also can get everything to work like it should, I'm able to have the settings in my template, and in case I want to have different attribute values ready to load I can do that now too with the new version, since saving the mappings in the .sda file works the way it should.

Thanks a lot for your great support throughout these issues, I appreciate it.

Great!

Reply to Discussion

RSS

About

Render Plus created this Ning Network.

Search


Enter a phrase here to search the entire Render Plus web site:

Loading

Translate

Latest Activity

© 2019   Created by Render Plus.   Powered by

Badges  |  Report an Issue  |  Terms of Service