Render Plus Software

After I finally got myself a license, while tweaking the attributes (calculations) of my current template to add lengths to names of components I ran across a bunch of crashes and then an unexpected problem.

Some minutes and crashes before the main problem appeared, SketchUp+SpaceDesign developed the habit of me having to create a PDF report twice, the first time it would delete the old file in the folder but then not create a new one. The second time I would click report it would work normally, but only if there was no file with the same name to delete. It's like something internal to SpaceDesign was broken.

After one of the later SketchUp crashes, SpaceDesign wouldn't load automatically at start of SketchUp anymore (the checkbox was empty, manually setting it again would not help however), and along with it wouldn't create PDF reports at all anymore. When trying to create a report I get the typical window, where it processes stuff, but when it's gone I get no opened PDF and the according folder has no new file either. It'll still delete an old file, but will never create a new one.

The other features  (like .csv reporting) seem to be still working normally after SpaceDesign was manually loaded.

My question on this topic is: Is this a known problem? If not, what files and information could I submit to help fix it?

(Some other questions for which I can make seperate threads if demanded:

1. Blank if zero is supposed to make fields appear empty in the report instead of showing a zero, right? Because for me it doesn't seem to be doing anything at all.

2. .csv files are saved with [,] as the seperator sign between cells {Count,Preis,Beschreibung,...}, some versions of Excel like german however use [;] as the seperator sign{Count;Preis;Beschreibung;...}. Is it possible to switch this somewhere in the program or could this feature be added? It's rather inconvenient to always have to change the file in some way before using it.)

Views: 207

Reply to This

Replies to This Discussion

This is not a known problem.

If you could send me your template drawing, perhaps I could duplicate this here. I'll set my Locale setting to German, to see if that's what's causing the trouble.

Also, a small model with a few attributes set might be helpful.

We'll also look into the problem with 'Blank if Zero' and using a different CSV field separator.

German might be the problem somewhere in the background. What I forgot to add above, even if it might've been written between the lines, is the fact that after it stopped making PDFs it stopped so completely, that is also with untouched previously perfectly working drawings.

Also I made a few short tests to confirm some things. This morning PDF reporting still did not work. When I switched to en_US it did work again though. And it did NOT stop working again after I switched back to de_DE, so switching back and forth seems to have fixed it at least temporarily.

I will take a look at which files caused the problems when, and then I'll send them over.

We posted a new version with a fix for the "Blank if Zero" problem, and added a new option to set the character to use as the delimiter for reports saved as CSV files:

You can download the new version here:

http://www.renderplus.com/wp2/download/

Also, we are now saving all of the files we create for making a SpaceDesign PDF report in a single folder, so that you can then zip up that folder's contents and send them to me if you are still having a problem. The path to that folder is:

C:\Users\[Your User Name]\AppData\Roaming\SpaceDesign\PDF_Data

 

I can't seem to properly install the new version, I always get the error message: "RPS_SpaceDesign folder not found. Please re-install the application."

The mentioned folder does exist though and it is in the right place, right between the other plugins I use. I still have the installer of the previous version which works fine, so it might be something with the new installer. The result was always the same, the new version worked neither when re-installed nor when I uninstalled and installed again.

Once it works I'll try again and see if the problem persists.

Is there any more text to the error message?  

I cannot duplicate the error here.

Nope, that's all I get unfortunately.

After trying with english (USA) locale I get the same result. The old version installs and works fine. While installing the new version I get no errors of any kind and the folders seem to look about right, but upon starting SketchUp and trying to load the new version (automatically or manually) I get the small error message mentioned above, but nothing else.

I can hardly make sense of that error, the used references, folders, their names and locations as far as I can see them in the plugin folder all stay the same, so I have no clue why the new version drops that error. If both installing newer and older versions works fine on your side the problem sounds hard to locate, because the error message is genuinely unhelpful.

I will think about it during the weekend, maybe I get some ideas on what's going on. Maybe it's SketchUp at fault somewhere though.

I found the bug and posted a new version.

Please try that. Thanks.

I've tried the new version, it installs normal again, and the .csv delimiter function works perfectly. Blank if Zero also does work now, but just somewhat, I have an example picture of what I have now:

Here's how the fields are calculated:
length =  %DC: type% == 1 ? %DC: leny% * 10 : 0
length2 =  %length%
description =  %model_no% %length2%

So here's the list of bugs or at least non-obvious behaviours I found:
1. Even though the actual value of length and length 2 is obviously the same, as 2 only copies from 1, Blank if Zero only works with 2. This is not due to the calculation as it may seem, but rather due to the choosen amount of Dec. in the attributes. Blank if Zero works for all values, except if Dec. == 0
2. When I try to add something like the length to a name a 0 will be displayed even when the field it takes the value from is marked as Zero if Blank, ZiB will also only work on numeric fields, this makes it hard to append values to texts only in certain cases as ruby calculations also only take place in numeric fields
(3.) Appending a number to a text like this causes it to always display the full number, as Dec. is completely ignored. This is not really a problem though as rounding can just take place before putting it in there

Reply to Discussion

RSS

About

Render Plus created this Ning Network.

Search


Enter a phrase here to search the entire Render Plus web site:

Loading

Translate

Latest Activity

Felix Sim posted photos
Oct 8
Felix Sim posted a photo
Oct 8
Ponch Herrera posted photos
Sep 10
Vringo Vargas posted photos
Sep 3

© 2019   Created by Render Plus.   Powered by

Badges  |  Report an Issue  |  Terms of Service