I am using SketchUp 2017 on a Windows 10 PC with the newest version of 3DPDF.  When I create a 3D PDF, the PDF has two buttons at the bottom of the page - one says "Show Image" and the other says "Show 3D Model".  These buttons are new to me.  If I select Show Image, the edge lines appear on the model but it is a still shot.  If I select Show 3D Model, the edge lines disappear.  When creating the PDF, I have "ALL" Edge Lines selected and have tried various widths.  The SketchUp file is 87 mgb in size.  Do you know what is going wrong?  Thanks, John

Views: 259

Reply to This

Replies to This Discussion

To not see those "Show Image" and "Show 3D Model" buttons, check this box:

Those button just toggle between the original SketchUp image and the 3D model.

I'm not sure why you're not seeing any edge lines. I get them in a model I just tested here.

Maybe make a small model and send it to use to try here.

What version of 3D PDF are you running?

Make sure it's the latest one posted: PL06.

http://www.renderplus.com/wp2/download/

Aha! Also check this box:

Edge lines don't appear to be working in the new data extractor logic we are using now. This will go back to the old extraction method. That may be a little slower, but the edge lines should work OK.

Hi Rich,

I tried that checkbox and get this message (attached).  It fails to create the PDF.

Attachments:

Looks like it's running out of memory.

Does it work without any edge lines? Or with just "Orphans Only"?

Hi Rich, The attached file shows what happens with "Orphans only" selected.   So, If I have "All Edge Lines" selected, and don't have "Use legacy..." selected, the PDF works but has no edge lines.   If I change to "Use Legacy...", then I get the error message and no PDF is created.   Regarding memory, this PC has 16 GB of RAM - does that matter?

Attachments:

i looked at this again, and see that edge lines are working for me using the new extractor, but a few are missing:

I'll fix that and post a new version.

Could you make a small model where they are not working for you and let me use that for testing?

Hi Rich - I started eliminating some of the more complex entities in my model like roof tile details and finally got it to export to a useable 3D PDF with edges.  Maybe the models are just too big or complicated... Thank you for your help, John

There is a size limit that we run into. I's not any kind of number we can check, we just get an error back if the routine that we call that "compiles" the geometry runs out of memory.


John Cates said:

Hi Rich - I started eliminating some of the more complex entities in my model like roof tile details and finally got it to export to a useable 3D PDF with edges.  Maybe the models are just too big or complicated... Thank you for your help, John

Reply to Discussion

RSS

About

Render Plus created this Ning Network.

Search


Enter a phrase here to search the entire Render Plus web site:

Loading

Translate

© 2020   Created by Render Plus.   Powered by

Badges  |  Report an Issue  |  Terms of Service