Render Plus Software

SketchUp 2014 was released today!

To use Render Plus products with SketchUp 2014 you will need to download the latest version.

If your license is current, (purchased withing the past 12 months), it will work with SketchUp 2014.

If your license is more than 12 months old you will need to renew your license.

SketchUp 2014: Overview

Models galore, easier to find and use

SketchUp 2014 1.jpg


SketchUp’s universe of free 3D models is almost infinite; the improvements we’ve made to 3D Warehouse make that universe infinitely more useful. From fully-interactive model previews to an entirely new UI, the changes in 2014 are huge.

BIM classification and interoperability

SketchUp 2014 2.jpg


With SketchUp Pro 2014, you don’t have to sell a kidney or go back to school to start adding elements of BIM (Building Information Modeling) to your models. We added features for classifying objects and exporting files according to some of the industry’s most common BIM standards.

Time-saving tools for documentation

SketchUp 2014 3.jpg


When designing things that you will not be building yourself, it all comes down to the documents. LayOut in SketchUp Pro 2014 takes care of dates, page numbers, and repetitive text so you can focus on what matters: making better drawings.

SketchUp 2014. Now with more oomph

SketchUp 2014 4.jpg


Everyone wants SketchUp to get faster—especially us. That’s why we tweak the code every version to speed things up. This time, we supercharged shadows in big models and made vector rendering in LayOut more than ten times as quick.

Read More

New Versions of Render Plus Apps

SketchUp 2014 includes a new version of Ruby, and required that we update all of our Apps.

You will need to download the latest version of our Apps to use them with SketchUp 2014, and if you license is over 12 months old, you will need to renew your license to use it with SketchUp 2014.

Download new Version

IRender nXt , ArielVision, RPS 3D PDF , RpTools and SpaceDesign all have new versions and new downloads for use with SketchUp 2014.

Licenses

If your license is current, (purchased withing the past 12 months), it will work with SketchUp 2014.

(The second two letters of your license must be 'MC' or later to work with SketchUp 2014. e.g. IRMCxxxxx, IRMD, IRME, ... IRNB, etc.)

If your license is more than 12 months old you will need to renew your license.

Special SketchUp 2014 Renewal Prices

If you renew you license in order to use SketchUp 2014 prior to April 1, 2014, using this link, you will receive a 20% discount on the renewal price.

You can renew it here: Renewals with 20% discount

See also

Views: 15615

Reply to This

Replies to This Discussion

I installed sktechup 2014 and the latest Irender nxt but once I am in sketchup I can not get any of my irender tools bars to come up. I do see the irender within my plugin drop down window but all it says is iRender nxt - load. when I click on it it does nothing.

Here is the error message I get when I try and load irender within Sketchup:

$irender_nxt_release_folder: C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt
CASE(3)
RELEASE - MODE: 3 dll_name: C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt\bin_nXt/IRender_nXt_20_2010.so
AFTER CASE - MODE: 3 dll_name: C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt\bin_nXt/IRender_nXt_20_2010.so
IRender_nXt: @app_name: IRender_nXt dll_name: C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt\bin_nXt/IRender_nXt_20_2010.so
@dll_folder: C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt\bin_nXt
dll_name: C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt\bin_nXt/IRender_nXt_20_2010.so
GETWD: C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt/bin_nXt
DLL EXISTS: C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt\bin_nXt/IRender_nXt_20_2010.so
RPS_WIN32: C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt\bin_nXt/RPS_win32_IRender_nXt.so
Error: #<LoadError: 126: The specified module could not be found.   - C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt/bin_nXt/RPS_win32_IRender_nXt.so>
C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt/ruby/ardll_dcl.rb:123:in `initialize'
C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt/ruby/ardll_start.rb:60:in `new'
C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt/ruby/ardll_start.rb:60:in `start_irender'
C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt/ruby/Irender_base.rb:237:in `load_irender'
C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt/ruby/Irender_base.rb:283:in `load_irender_nxt_installed_release'
C:/Users/Paul/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt/ruby/Irender_base.rb:478:in `block in <top (required)>'
-e:1:in `call'

We just found a bug that was keeping IRender nXt from loading correctly in 2014.

We're fixing it and will post a new install after we build it and test it a bit.

OK, will you post on this discussion when it is ready?

We fixed this.

Please try the new version, NB28, on the download site:

http://www.renderplus.com/wp2/download/

Thanks,

Rich

Thank you. That worked.

Great! 

I tried the new version with SketchUp 2014 and still cannot access IRender - no plugin window and doesn't show under Preferences-Extensions. 

Do you mean that Plugins is not a menu choice at all for you in SketchUp 2014?

Yes.  No plugins option and iRender doesn't show under Preferences - extensions.

Could you open the Ruby Console window and type in:

load 'RPS_IRender_nxt.rb'

and then:

load 'RPS_IRender_nxt/RPS_IRender_nxt2.rb'

To see what errors we see?

I see:

load 'RPS_IRender_nxt.rb'
**** Loading: C:/Users/rich/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nxt.rb
true
load 'RPS_IRender_nxt/RPS_IRender_nxt2.rb'
**** Loading: C:/Users/rich/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nxt/RPS_IRender_nxt2.rb
$irender_nxt_release_folder (after find_rps_application_folder): C:/Users/rich/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt
Loading: C:/Users/rich/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt\Ruby\rps_common_ruby.rb
IRender_nXt : : USE_DEBUG_FILE:c:/devc_2005/debug_mode.txt exists: false
$irender_nxt_debug_folder: c:/devc_2005/IRender_nXt/ardll_debug
LOADING nXt stable Irender_base.rb: C:/Users/rich/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/RPS_IRender_nXt/ruby/Irender_base.rb
***** Loading: Irender_base.rb

etc.

load 'RPS_IRender_nxt.rb'

Error: #<LoadError: cannot load such file -- RPS_IRender_nxt.rb>

<main>:in `load'

<main>:in `<main>'

-e:1:in `eval'

Nil

 

load 'RPS_IRender_nxt/RPS_IRender_nxt2.rb'

Error: #<LoadError: cannot load such file -- RPS_IRender_nxt/RPS_IRender_nxt2.rb>

<main>:in `load'

<main>:in `<main>'

-e:1:in `eval'

Nil

Reply to Discussion

RSS

        

Translate

Latest Activity

Elekes Sandor posted photos
Sep 19
ana pin posted photos
Sep 18
Neil Philip Nebrija posted photos
Sep 15
Elijah posted photos
Sep 13

© 2017   Created by Render Plus.   Powered by

Badges  |  Report an Issue  |  Terms of Service